Электрон55.ру

 

Puppy-420-ru и графические редакторы

Графический редактор вещь достаточно нужная и часто используемая, в Linux есть много подобных приложений, например, в Puppy-420-ru, уже "встроены" программы InkLite и mtPaint, соответственно редакторы векторной и растровой графики.

Также в Linux популярен мощный графический редактор GIMP, поэтому - немного о его использовании совместно с Puppy-420-ru. Считаем, что у нас имеется установленная и работающая система, в варианте frugal. Существует SFS-модуль русифицированного редактора GIMP версии 2.6.4, он предназначен для использования в системе PuppyRus Jeans 1.3.0, но его можно запустить и в Puppy-420-ru, для этого:

1. Загружаем и устанавливаем пакет D-Bus. 

2. Загружаем и устанавливаем пакет GLib версии 2.16.1 или новее.

3. Загружаем и копируем в /usr/lib библиотеку libdbus-glib-1.so.2 (можно загрузить здесь)

4. Загружаем SFS-модуль редактора, кликаем по нему правой кнопкой и выбираем "Подключить модуль SFS", ждём сообщения об удачном подключении, в "Меню"->"Графика" появится пункт "Gimp".

Небольшое замечание - при запуске GIMP в терминале, видно, что есть какие-то сообщения об ошибках, в частности о xsane - это что-то связанное со сканерами, и ещё нечто не совсем понятное, но тем не менее редактор запускается и работает в Puppy-420-ru.

Ещё один графический редактор - ImageMagick, также весьма интересный, консольный, т.е. без GUI. Для его использования в Puppy-420-ru:

1. Загружаем и устанавливаем пакет редактора.

2. Загружаем и устанавливаем пакет libcroco.

3. Загружаем и копируем в /usr/lib библиотеки: libglitz.so.1libwmflite-0.2.so.7 (архив с этими библиотеками можно загрузить здесь) и libdjvulibre.so.15 (можно взять из этого пакета).

Все перечисленные выше библиотеки для GIMP и ImageMagick, указаны, для случая "чистой" системы, т.е. когда ещё не устанавливались никакие пакеты. В случае же, уже установленных каких-либо программ, необходимость копировать те, или иные библиотеки может отсутствовать, например, если установлен пакет для работы с djvu, то библиотека libdjvulibre.so.15, вероятно, уже присутствует в системе.

На сайте "Электрон55.ру" работает форум.
 
Читайте также :

» Моё знакомство с Linux

Моё знакомство с Linux состоялось в достаточной степени случайно - в сентябре 2009 года я читал в Википедии про процессоры, про ARM вроде-бы, в...

» LupuRUS 510 (Lucid Puppy 5.1)

Достаточно долгое время я использовал на своём домашнем компьютере ОС , но вот летом 2010 года, на , прочитал про появившийся новый...

» Puppy-420-ru и USB-модем ZTE MF626

Можно сказать, что одним из первых серьёзных "испытаний" в освоении Puppy Linux, для меня стало подключение USB-модема ZTE MF626. В Windows всё привычно...

» LupuRUS 510 и менеджер паролей KeePassX

В определённый момент времени, в связи с довольно большим количеством накопившихся паролей, для всевозможных ресурсов, встал вопрос о...

» Puppy-420-ru: разное

Здесь будут публиковаться замеченные мной при работе данной системы ошибки, небольшие советы, замечания, рекомендации и т.п. для...